[Catalyst] apache2 fastcgi

shawn wilson ag4ve.us at gmail.com
Sun Mar 13 12:54:28 GMT 2011

i'm trying to deploy a project on apache2. first, i tried by hand with this

<VirtualHost *:80>
   DocumentRoot /var/www/Shell/root
   Alias /static /var/www/Shell/root
   ErrorLog /var/log/apache2/error.log
   <Location /static>
      SetHandler default-handler
   Alias / /var/www/Shell/script/shell_fastcgi.pl/
   <Location />
      Options ExecCGI
      Order allow,deny
      Allow from all
      AddHandler fcgid-script .pl

and i get this in my error log:

[Sun Mar 13 08:40:46 2011] [error] [client] File does not
exist: /var/www/Shell/script/shell_fastcgi.pl/main

then, i tried this, pretty much verbatim from Catalyst::Engine::FastCGI pod:

<VirtualHost *:80>
   DocumentRoot /var/www/Shell
   ErrorLog /var/log/apache2/error.log
   <Directory /var/www/Shell>
      Options +ExecCGI
   <Files shell_fastcgi.pl>
      SetHandler fastcgi-script

and i get this in my error log:

[Sun Mar 13 08:48:37 2011] [error] [client] client denied by
server configuration: /var/www/Shell/main

i'm pretty sure that the second config is wrong (as there's no main in the
root there and it's not running the fastcgi script) however the former
config looks like it almost should work? btw, i haven't modified the
fastcgi.pl script from the default that catalyst created for me.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20110313/51aa5=

More information about the Catalyst mailing list