[Catalyst] Can the latest Catalyst version from CPAN be installed under Windows?

John Napiorkowski jjn1056 at yahoo.com
Fri Sep 9 01:21:31 GMT 2011

I'd really love to see some logs of this problem. =A0I am on MacOSX and don=
't have problems of this magnitude when installing Catalyst. =A0However I d=
on't use the built in system Perl, I use Perlbrew + local::lib + cpanm as m=
y primary build toolchain. =A0If I use a modern Perl (5.12+) the only thing=
s that give me trouble is the bit of extra work it takes to install DBD::my=
sql (need to make sure you set the ENV var to point to the mysql_config uti=
lity if that is not in $PATH).

I know Catalyst does have quite a few dependencies, but I round tripped ins=
talling Catalyst and Task::Catalyst many times as part of the testing I did=
 prior to the latest release, so I know that it can work (abet a bit time c=
onsuming to run all the tests for all the dependencies). =A0If you follow t=
he generally promoted process:

1) Setup a local Perl with perlbrew and a modern Perl.
2) Create and activate a local::lib where you dependencies will go (in othe=
r words never install stuff into the perlbrew managed Perl)
3) use cpanm

You should have little trouble. =A0Again, I'd love to see the logs. =A0I kn=
ow the temptation to use some sort of port system here is quite high, but m=
y experience is that this is not a great path for developers and the port/d=
eb/rpm etc. almost always get something wrong that causes you pain in the e=

Just my experience. =A0Hope this helps.


>From: Tom Keller <kellert at ohsu.edu>
>To: The elegant MVC web framework <catalyst at lists.scsys.co.uk>
>Sent: Thursday, September 8, 2011 4:30 PM
>Subject: Re: [Catalyst] Can the latest Catalyst version from CPAN be insta=
lled under Windows? =

>If you are on OS X, you can use MacPorts to install Catalyst. I had tried =
using CPAN, but got seemingly circular errors as well.
>MMI DNA Services Core Facility
>kellert at ohsu.edu
>Office: 6588 RJH (CROET/BasicScience)
>OHSU Shared Resources
>On Sep 8, 2011, at 1:05 PM, Octavian Rasnita wrote:
>> Hi,
>> =

>> I have tried to install Catalyst with CPAN, but it gave an error telling=
 that it has a missing dependency in Plack::Test::ExternalServer.
>> =

>> That module couldn't install because of a test error (something like a m=
issing empty port or something like that)
>> =

>> So I force installed Plack::Test::ExternalServer, but after this step, w=
hen I tried to install again Catalyst, it gave more errors:
>> =

>> Failed 107/141 test programs. 15/385 subtests failed. =

>> =

>> Octavian
>> =

>> =

>> _______________________________________________
>> List: Catalyst at lists.scsys.co.uk
>> Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
>> Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.=
>> Dev site: http://dev.catalyst.perl.org/
>List: Catalyst at lists.scsys.co.uk
>Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
>Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
>Dev site: http://dev.catalyst.perl.org/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20110908/2d981=

More information about the Catalyst mailing list