[Catalyst] using perldoc on VM

Kamen Naydenov pau4o at kamennn.eu
Mon Jun 11 18:19:47 GMT 2012

Hi John

On Mon, Jun 11, 2012 at 7:08 PM, John Deighan <john.deighan at gmail.com> wrote:
> It is, in fact, a Debian linux system. That's not a specific system I'm
> familiar with. And I did try following the instructions. It said that I
> needed to install perl-doc, so I tried the obvious:
>        install perl-doc
> which, of course, did not work. I knew nothing about apt-get and shouldn't
> be expected to. Now, here's more bad news. I tried using apt-get and here's
> what I got back:
> root at catalyst:/home/catalyst/MyApp# apt-get install perl-doc
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Package perl-doc is not available, but is referred to by another package.
> This may mean that the package is missing, has been obsoleted, or
> is only available from another source
> However the following packages replace it:
>  perl
> E: Package 'perl-doc' has no installation candidate
You need to have properly configured sources.
To check your sources run this command:
grep -Ev '^(#| )' /etc/apt/sources.list

On my stable Debian server output is:
deb http://ftp.debian.org/debian/ squeeze main
deb http://security.debian.org/ stable/updates main

If you don't hvae similar output you will need to edit /etc/apt/sources.list
May be with command:
sudo gedit /etc/apt/sources.list

You can copy and paste lines from output shown above at the bottom of
file, than save and exit gedit;
After this run following commands:

More information about the Catalyst mailing list