[Catalyst] using perldoc on VM

John Deighan john.deighan at gmail.com
Mon Jun 11 16:08:44 GMT 2012

It is, in fact, a Debian linux system. That's not a specific system I'm 
familiar with. And I did try following the instructions. It said that I 
needed to install perl-doc, so I tried the obvious:

	install perl-doc

which, of course, did not work. I knew nothing about apt-get and 
shouldn't be expected to. Now, here's more bad news. I tried using 
apt-get and here's what I got back:

root at catalyst:/home/catalyst/MyApp# apt-get install perl-doc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package perl-doc is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:

E: Package 'perl-doc' has no installation candidate

Not only is it telling me that there is no perl-doc package to install 
(contrary to the message I receive when trying to actually use perldoc), 
it seems to be telling me that the 'perl' package should take care of 
it. That's exactly what I'd expect, but perl is pre-installed on this VM 
and yet perldoc doesn't work. Rather unfortunate. Anyway, I can get any 
documentation I need by searching the web (on my Windows laptop), so 
it's not critical, just annoying.

On 6/11/2012 10:33 AM, Lyle wrote:
> On 11/06/2012 15:05, Lukas Thiemeier wrote:
>> On 06/11/2012 03:38 PM, John Deighan wrote:
>>> I'm using the Catalyst VM that accompanies the catalyst tutorial. I'm
>>> currently unable to use perldoc:
>>> catalyst at catalyst:~/MyApp$ perldoc Session::Store
>> This highly depends on your distribution, and is totaly unrelated to
>> catalyst.
> Not so. As specified he is using the tutorial VM provided by shadow cat
> and recommended in the Catalyst tutorial:
> http://cattut.shadowcat.co.uk/
> They have failed to include perldoc in their VM image which is rather
> embarrassing. I suspect it's a debian image, but it doesn't actually
> specify on the download page, and I don't have time or inclination to
> download it just to find that out.
>> On debian based systems, "perldoc" is included in the package
>> "perl-doc", so you can install it by runnig "apt-get install perl-doc"
>> as root.
>> Since the output on your console says "You need to install the perl-doc
>> package...", a reasonable first step would be to follow these
>> instructions and install the perl-doc package!
> It's a reasonable assumption to expect perldoc be included with the
> Catalyst VM.
>> On redhat based systems, perldoc should be included in in the main perl
>> package, but it has been a while since I was working on redhat, so i am
>> not sure if this is right.
>> If you build your own perl, e.g with "perlbrew" (which I recommend)
>> perldoc should be included.
> As he stated in the original post, he's using the Catalyst tutorial VM.
> Lyle
> _______________________________________________
> List: Catalyst at lists.scsys.co.uk
> Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
> Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
> Dev site: http://dev.catalyst.perl.org/

More information about the Catalyst mailing list