[Catalyst] Role problems, Still

Kenneth S Mclane ksmclane at us.ibm.com
Wed May 23 15:37:43 GMT 2012

I am having difficulty in getting my user to authenticate against the 
second realm. After successfully authenticating against the ldap server, I 
want to authenticate against the dbic realm as well as that is where the 
roles are stored. It seems to ignore a second call to $c-.authenticate.

I tried removing the "default_realm => 'ldap'" entry but it complained 
with an error of not find the user in the realm "default". 

I looked at the "Progressive" module, but it seems to me that it stops as 
soon as the user authenticates.

I also have had no luck doing a find_or_create. Do I need to consolidate 
the roles into the users table? 

I even tried just creating a user in the user table figuring I could do a 
second step of updateing the users_to_roles table after that. I keep 
getting "me.user is not valid in the context it is being used"

Once again I can find no help in the docs. They simply do not address this 
situation. I have found that other people have solved this, but they don't 
seem to post the code that solved it, just something along the lines of "I 
fixed it". That isn't of much help to us new folks.

Any help is appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.scsys.co.uk/pipermail/catalyst/attachments/20120523/04023fe9/attachment.htm

More information about the Catalyst mailing list