[Catalyst] "Connection reset by peer" when using CPAN do download Catalyst

Jorge Gonzalez jorge.gonzalez at daikon.es
Tue Nov 8 17:28:05 GMT 2016

I'm not a CPAN maintainer, but IMHO the error code points to some
network error (probably intermittent) on your VirtualBox on Windows,
since you mention that on an Ubuntu host the error does not occur.

This links may be related...?




Found them by googling for "ubuntu virtualbox windows 7 connection reset
by peer"

Re: the bug report on CPAN module, I assume it will be closed shortly as
not relevant.



Jorge González Villalonga
Ingeniero de Sistemas / Systems Engineer
Red Hat Certified Engineer #140-183-666
Móvil / Cell: (+34) 672 173 200

La información contenida en este mensaje y/o archivo(s) adjunto(s) es
confidencial/privilegiada y está destinada a ser leída sólo por la(s)
persona(s) a la(s) que va dirigida. Si usted lee este mensaje y no es el
destinatario señalado, el empleado o el agente responsable de entregar
el mensaje al destinatario, o ha recibido esta comunicación por error,
le informamos que está totalmente prohibida, y puede ser ilegal,
cualquier divulgación, distribución o reproducción de esta comunicación.
Le rogamos que nos lo notifique inmediatamente y nos devuelva el mensaje
original a la dirección arriba mencionada. Gracias.

El 08/11/16 a las 16:13, Duncan Garland escribió:
> Hi,
> I know this isn't strictly a Catalyst question, but it's preventing me
> downloading Catalyst (or anything else) from CPAN onto my VirtualBox VMs.
> I posted a bug report for the CPAN module 12 days ago but nothing has
> happened.
> I work a lot with Ubuntu VMs on a Windows host. Everything worked fine
> until a month or so ago.
> I've got Windows 7 at work and Windows 10 at home. The problem occurs
> with any combination of Ubuntu 12.04, 14.04 or 16.04 on Windows 7 or
> Windows 10.
> The problem doesn't occur with 14.04 on an Ubuntu 16.04 laptop as a
> host. A Rackspace Ubuntu 16.04 server seems OK.
> I've tried several different CPAN mirrors.
> I can download and install CPAN modules manually (by clicking the
> "Download" link on the web page.)
> The problem is that 90% of the time, I get this sort of thing:
> Running make install
>   Delayed until after prerequisites
> Running install for module 'Starman'
> Running make for M/MI/MIYAGAWA/Starman-0.4014.tar.gz
> Fetching with LWP:
> http://www.pirbot.com/mirrors/cpan/authors/id/M/MI/MIYAGAWA/Starman-0.4014.tar.gz
> Catching error: "read failed: Connection reset by peer at
> /usr/local/share/perl/5.18.2/LWP/Protocol/http.pm <http://http.pm>
> line 465. at /usr/local/share/perl/5.18.2/LWP/UserAgent.pm line
> 916.\cJ" at /usr/share/perl/5.18/CPAN.pm line 392.
>     CPAN::shell() called at /usr/share/perl/5.18/App/Cpan.pm line 338
>     App::Cpan::_process_options('App::Cpan') called at
> /usr/share/perl/5.18/App/Cpan.pm line 421
>     App::Cpan::run('App::Cpan') called at /usr/bin/cpan line 12
> That's the output from installing Module::Install::Catalyst. The place
> at which is stops varies, it isn't always Starman. However, it's very
> rare for the whole install to complete successfully.
> The problem occurs with CPANplus and cpanm as well.
> Does anybody have any ideas what's going on? Or how to troubleshoot
> why the server is closing the connection?
> All the best.
> Duncan
> -- 
> *Duncan Garland*
> Perl Team Leader
> The information contained in this message is for the intended
> addressee only and may contain confidential and/or privileged
> information. If you are not the intended addressee, please delete this
> message and notify the sender; do not copy or distribute this message
> or disclose its contents to anyone. Any views or opinions expressed in
> this message are those of the author and do not necessarily represent
> those of Motortrak Limited or of any of its associated companies. No
> reliance may be placed on this message without written confirmation
> from an authorised representative of the company.
> Registered in England 3098391 V.A.T. Registered No. 667463890
> _______________________________________________
> List: Catalyst at lists.scsys.co.uk
> Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
> Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
> Dev site: http://dev.catalyst.perl.org/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.scsys.co.uk/pipermail/catalyst/attachments/20161108/e89f546a/attachment.htm>

More information about the Catalyst mailing list