[DBD-SQLite] Weird UTF-8 problem (solved)

Kenichi Ishigaki kishigaki at gmail.com
Tue Nov 3 03:26:26 GMT 2009

Both "sqlite_unicode" and "unicode" attributes access
the same internal handle attribute (imp_dbh->unicode),
so basically it shouldn't matter which attribute name
is used in the DBD::SQLite arena. However, it's possible
your application, or your O/R mapper maybe, does something
for you when it has its own "unicode" attribute as a connect
option. Thanks for the report.


On Mon, 02 Nov 2009 21:18:52 +0100, Michael Lackhoff <michael at lackhoff.de> wrote:

>>> I will check the 1.26 dev versions.
>> I just checked them all. The change is from 1.26_05 to 1.26_06. All
>> versions from 1.25 to 1.26_05 loose the UTF-8 flag, only 1.26_06 is ok.
>Found it. I had a connect option "sqlite_unicode => 1" plus this
>attribute setting: $dbh->{unicode} = 1;
>My thought was that this would satisfy both attribute names (or just
>because I tried everything to get it working). But in the web app the
>$dbh->{unicode} setting was ignored for whatever reason. Everything
>started working as soon as I changed the connect option to
>"unicode => 1". This was recognized by all the versions (but won't for
>future versions?)
>Sorry for all the hazzle
>DBD-SQLite mailing list
>DBD-SQLite at lists.scsys.co.uk

More information about the DBD-SQLite mailing list