[Catalyst] Catalyst on Windows advice needed

Stuart McGraw smcg4191 at frii.com
Tue Apr 18 19:59:51 CEST 2006

"Nilson Santos Figueiredo Junior"  wrote:
> On 4/17/06, Stuart McGraw <smcg4191 at frii.com> wrote:
> > I recently read about Catalyst and it sounded great.
> > I need to run it on MS Windows (with IIS -- that is
> > a requirement).  I have spent friday and this entire
> > weekend trying to install it on a Windows 2k machine
> > with Activestate perl-5.8.8-817.  I have tried using
> > the ppm packages at uwinnipeg.  I have tried building
> > the cpan packages.  I have tried following various
> > googled instructions. I have tried the shadowcat script.
> > I have tried various combinations of the above in various
> > orders.  For 3 days.
> What sort of errors did you get, exactly?
> I've been running Catalyst under Win32 with AS Perl 5.8.7 and 5.8.8,
> using Apache 1/2, Visual Studio and GCC environments and it's running
> smoothly. You can install everything from the CPAN shell provided
> you've got a suitable compiling environment. Having a Visual Studio
> environment makes things a little bit easier but GCC works fine.

I was encouraged to read that you built almost everything and
it ran ok with Perl-5.8.8 so I gave it another shot.  I have
MSVC-6.0 compiler.  I used the shadowcat script to intall the 
core stuff.  It installs mosty from ppms but uses cpan for a 
few things.  That seemed ok except for 1 missing ppm which 
I installed from cpan.

But task-catalyst has been a nightmare.
Almost every module failed because of missing dependencies.
So I make a list and manually installed the depencies from
cpan.  After futzing with the order of things, most things 
installed (I had to remove the inc/ directory on a few as 
you mentioned) but still have problems with

  had a zillion C errors, so installed v1.11 from ppm.

  many tests ran but lots of these errors:
  t\cdbi-t\22-self_referential........Attempt to free unreferenced scalar: SV 0x23
  69e10, Perl interpreter: 0x162445c at C:/Perl/site/lib/SQL/Abstract/Limit.pm 
  line 325.

  <...failed many tests...>

  tests generate deref-null-pointer access violations

  t/05edit...........ok 1/26
  Permission denied at C:\Perl\cpan\build\Authen-Htpasswd-0.14\blib\lib/Authen/Htpasswd.pm 
  line 253,  <GEN0> line 4.
  # Looks like you planned 26 tests but only ran 1.
  # Looks like your test died just after 1.
  Test returned status 255 (wstat 65280, 0xff00)

Some of the above (e.g. Class-Throwable and DBIx-Class)
I found ppms for and installed those, but no ppm for
Authen::Htpasswd so not sure what to do there.

Also, I'd prefer to use the cpan packages directly as much 
as possible to reduce my dependence on a middle-

Now I am having the same problem I had with an earlier
install -- when I run the tutorial_server.pl script, I get an
error message that starts:

  Couldn't load "tutorial::View::TToolkit", "Invalid CODE attribute: Private 
  at C:/xx/tutorial/script/../lib/tutorial/View/TToolkit.pm line 6
  BEGIN failed--compilation aborted at ...

Any idea what that's about?

More information about the Catalyst mailing list