[Catalyst] SchemaLoader?

Nilson Santos Figueiredo Junior acid06 at gmail.com
Mon Dec 25 04:42:53 GMT 2006

On 12/25/06, Octavian Rasnita <orasnita at gmail.com> wrote:
> Can you tell me what version of perl do you have? I use ActivePerl 5.8.8
> build 819.

Same here.

Have you tried updating DBI itself (not DBIx::Class), using the CPAN
shell, as I've said before? That usually does away with those
unreferenced scalars warnings.

Note that, in order to properly install DBI you'll need to have a
properly configured C compiling environment. Under Win32 using AS Perl
you can achieve that by either having Microsoft Visual C++ installed
or by having a working gcc (mingw) environment. Since MSVC licenses
are expensive, I'll assume you don't have one and you'll follow the
gcc path. The easiest way to get everything working using gcc is to
install Bloodshed Dev-Cpp with is an open source IDE-wannabe. After
that you'll just need to set up some environment vars and your CPAN
shell will automatically recognize what it calls a "gcc environment".

There's also something called Strawberry Perl, which supposedly makes
things easier. When I've tried it, I couldn't get things to work at
all, so I prefer the AS Perl + Dev-Cpp combo. It's a tried and tested
setup, which I've replicated to many boxes already.

If you've already got all of this set up, you can ignore it and just
try updating DBI and, hopefully, your problems will be gone.

-Nilson Santos F. Jr.

More information about the Catalyst mailing list