[Catalyst] Basic CRUD example failing

Cesare Gargano gar at plusiagamma.org
Wed Oct 28 10:36:18 GMT 2009

Hi guys!

During these days p5-Catalyst-* has been updated on OpenBSD
ports tree (as you know): what version of p5-Catalyst-* are you

I ask that because I've followed all tuts w/ old (5.7..) Catalyst
version on OpenBSD, and it didn't work until I updated it to 5.8
(in particular Catalyst::Model::DBIC::Schema didn't work as it
should be: it didn't create the "Result" subdirectory; and also
following the NOTE for older version didn't work). I solved all
these problems updating to the latest version.

But perhaps, catalyst version is not the problem...

Best regards,

On Wed, Oct 28, 2009 at 01:07:02AM -0400, Jason Dixon wrote:
> Hi all,
> Learning Catalyst here.  Following along with the manual and I ran into
> a weird issue.  I assume the documentation is right so it must be
> something with my installation (Catalyst packages on OpenBSD 4.6).
> Following along with the "SIMPLE DELETE FEATURE" example, I made changes
> to root/src/books/list.tt2.  Alas, the uri is not rendering properly.
> <a href="[% c.uri_for(c.controller.action_for('delete'), [book.id]) %]">Delete</a>
> This ends up with a series of ARRAY values, e.g.:
> http://localhost:3000/books/ARRAY(0x88328620)
> I'm not sure if this is a problem with my Model (DBIC), Controller or
> something else.  Any suggestions?
> Thanks,
> -- 
> Jason Dixon
> DixonGroup Consulting
> http://www.dixongroup.net/
> _______________________________________________
> List: Catalyst at lists.scsys.co.uk
> Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
> Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
> Dev site: http://dev.catalyst.perl.org/

More information about the Catalyst mailing list