[Catalyst] Simple question about "use Catalyst"

Denny 2015 at denny.me
Mon Oct 19 13:35:07 GMT 2015

On Mon, 2015-10-19 at 14:21 +0100, Andrew wrote:

> I ran catalyst.pl to create a new app (at least I think that's how I
> did it - it was a couple of days back now),
> and when I opened the main pm file, near the top was:
> use Catalyst::Runtime 5.80;
> I'd just installed Catalyst 5.90101 via cpanm, so wasn't sure why 5.80
> was written there (for compatibility reasons?),
> so as I modify the script to suit my purposes, I've changed it to:
> use Catalyst::Runtime 5.90101;
> ...does it do anything, or make any difference?

It means anyone else who uses your application (and/or any other
machines you install it on yourself) will also have to have the newer
version of Catalyst installed.

If your app doesn't need any features that are in 5.9 but not in 5.8,
and you're not releasing it to the public, then it's probably not worth
changing it, but it won't hurt either way.  If you are releasing it to
the public, changing it will cause problems for other people who are
still running 5.8 on their machines.

If your app does need features that are only in 5.9 and you're releasing
it to the public, then of course you must change it, so anyone else
installing your app knows what libraries they'll need to

More information about the Catalyst mailing list